PostgreSQL to Oracle FAQ

[PostgreSQL to Oracle Converter]  [Download]  [Buy]

This page contains answers for the most frequently asked questions regarding PostgreSQL to Oracle converter. If some question is not answered here, please ask Intelligent Converters support team via Feedback Form

What versions of PostgreSQL and Oracle are supported?
PostgreSQL to Oracle database migration tool works with all versions of PostgreSQL and Oracle servers running on Linux/Unix and Windows systems.
Go to Top

How to avoid the error "The ordinal XXXX could not be located in the dynamic link library LIBEAY32.dll."?
The error means that one of required DLLs is missing in the system. Check that client or server components of PostgreSQL are installed on the same machine where the converter is running. Also make sure that the path to PostgreSQL installation folder is included in $PATH system variable. If the problem persists, copy pgs2ora.exe into PostgreSQL BIN subfolder and try to run it again.
Go to Top

What are the system prerequisites for the application?
PostgreSQL to Oracle converter works on Windows XP (SP2 or SP3), Windows 2003, Windows Vista, Windows Server 2008, Windows 7, Windows 8 and Windows 10. Also, the program requires server or client components of PostgreSQL to be installed on the same machine.
Go to Top

Does PostgreSQL to Oracle migration tool support automation?
The program does not support automation directly. However, there is console version p2oagent.exe in the installation directory. It supports command line arguments and so it can be called from any script. Write simple batch script with single call of p2oagent.exe passing all necessary parameters and you will be able to run it recurrently using Windows scheduler. Refer to 'Command line' article of the product documentation for more details about p2oagent.exe.
Go to Top